Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 17, 2025 - 03:00 GMT+04:00
Scheduled
Our payment vendor in Georgia will be conducting essential technical maintenance work. During this period, there may be a brief interruption in e-commerce services specifically for Georgia merchants. This interruption is expected to last for approximately 1 hour. Please note that card operations for all types of commerce may be affected during this time. We apologize for any inconvenience this may cause and appreciate your understanding as we work to enhance your e-commerce experience. If you have any urgent inquiries or concerns, please feel free to reach out to our support team.
Posted Feb 13, 2025 - 12:18 GMT+04:00
This scheduled maintenance affected: Partner financial institutes.